Approve not working on workflow


#1

On the workflow for (https://circleci.com/workflow-run/e10f9466-eed4-4321-ab93-59a551e74365) I click the “On Hold” task and click “Approve”. The box disappears but the task is still On Hold


#2

I was not able to reproduce this issue on our side. Are you still experiencing it?


#3

Hi, I’m also experiencing this issue. When I click play, it stays as on hold. After refreshing, it looks like it’s successful but it never runs. There’s no time by the job, and it’s not clickable.


I tried again, and confirmed that the post to https://circleci.com/query-api was successful with the following payload (however the job still never started) when I approved the deploy-production job.

["~#list", ["~$job/approve", ["^ ", "~:job/id", "~u00000000-0000-0000-0000-000000000000", "~:run/id", "~u00000000-0000-0000-0000-000000000000"]]]

#4

Still observing this bug. I tried clicking on deploy-production again after clicking it the first time and I get a 400 response code with the following message. Refreshing has the same behavior where it looks like the job completed, but it didn’t.

Job 'e587c455-1007-49c8-8646-6d882e952a10' is not running


#5

We are experiencing this also. Any updates?


#6

Probably not, unless someone produces an example that a Circle employee can dig into. The first post may be an example (it won’t load for me, the browser just hangs) but @KunalJain indicates that was not reproducible anyway. Could you perhaps provide something concrete that could be looked into?


#7

Hey All,

Sorry for not posting back on here but it appears to be that you can’t have a task associated with the approval step.

The approval step has to be on it’s own the task that is needing approval needs to have a dependency on the approval step

Hope this makes sense

Lee


#8

@oilee80 is there an example config file you could show?


#9

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.