Android 7.1(25) build problem

android

#1

Build failing because of:

You have not accepted the license agreements of the following SDK components:
  [Android SDK Build-Tools 25].
  Before building your project, you need to accept the license agreements and complete the installation of the missing components using the Android Studio SDK Manager

It worked fine with android-24. My circle config:

dependencies:
pre:
- ( sleep 5 && while [ 1 ]; do sleep 1; echo y; done ) | android update sdk --no-ui --all --filter “tools,android-25,build-tools-25,platform-tools,extra-google-m2repository,extra-android-m2repository,extra-android-support,extra-google-google_play_services”


#2

I am also hitting the same problem - have gone back to android-24 for now.


#3

Looking more closely at the 2nd line after the error:
Alternatively, to learn how to transfer the license agreements from one workstation to another, go to http://d.android.com/r/studio-ui/export-licenses.html
It appears there maybe a way round this problem by copying the relevant licence file directory - refer:
https://developer.android.com/studio/intro/update.html#download-with-gradle


#4

Adding this to the pre-dependency commands worked for me:

if [ ! -d “/usr/local/android-sdk-linux/platforms/android-25” ]; then echo y | android update sdk --no-ui --all --filter “android-25”; fi


#5

Doesn’t work for me. Do you use build-tools-25?


#6

I was on build tool 23.0.3. I have since updated to 25.

This should solve the issues you’re having:

if [ ! -d “/usr/local/android-sdk-linux/platforms/android-25” ]; then echo y | android update sdk --no-ui --all --filter “android-25”; echo y | android update sdk -u -a -t 3; fi


#7

Found a problem, changed build-tools-25 to build-tools-25.0.0 and it started working.


#8

Thanks - that worked for me


#9