Almost all my tests failing unexpectedly, meta data not being collected


#1

Hi there.
All of my recent builds are failing, and almost all the tests are failing.
The error message is this
With some of our inferred build commands we collect test metadata automatically, but that didn't happen for this project.

Everything was working fine yesterday, but now my tests are failing. Most of the failing tests are passing in my local environment.

The only change to the circle.yml was to set cache_directories: but this was several days ago, and my tests were passing fine with that included.
None the less, I tried to rebuild the failing tests without cache, no luck.
I tried to rebuild a previously passing test, and now all the same tests fail on that rebuild.
I tried this with cache and without, both ways the same tests are failing in the same way.

We are using a LAMP stack, and this is a private project.

Thanks in advance.

Cloud


#2

We found out what this is related to. It seems like the mysql mode is set to strict. Our system inserts null values into the database, but normally there are no errors or warnings, and it inserts the null values anyways.
On strict mode, mysql should trow an error, and not insert any null values. We’re not sure why this is in strict mode, or how to change that, so we have tried, with some success to fix it by not entering null values to our insert calls.


#3

Turns out this was related to the newest wordpress release.
See this conversation for more Mysql mode is set to strict, how can I change this?


#4