Mysql mode is set to strict, how can I change this?


#1

Mysql mode is set to strict it seems, but we didn’t change any thing. I wonder if CI has made that change.
Now our system is throwing lots of sql errors and our tests are failing. Our system is trying to insert null values into the DB and usually this is fine. But yesterday, something changed, and now CI is throwing errors at us about Not Being able to insert NULL values.
Any ideas if CI changed something, or how we can change that setting.
Much appreciated.

PS We are on LAMP stack, private project, and the tests are passing locally.


#2

This issue was caused by us using the latest wordpress build. When the version changed, the database behaviour was more strict.
We solved this issue by changing in our Circle.yml file.
From

    - tar xfz latest.tar.gz```
To
```- wget https://wordpress.org/wordpress-4.3.1.tar.gz
    - tar xfz wordpress-4.3.1.tar.gz```

Almost all my tests failing unexpectedly, meta data not being collected
#3