Adding Project -- Project doesn't show up under list of projects for my organization

getting-started

#1

When I go to Add Project and click on the button for my organization (data-refinery which you can see here that I am an owner of) it lists a private repo but does not list the data_refinery which as you can see here should be listed.

Is there anything I can do to make that repo appear? I have verified that I have “already granted this app access to GitHub outside of GitHub Marketplace” where this app is CircleCI. I’m not sure if this is relevant or not but this project used to be part of a different organization but was moved into data-refinery.


#2

This sorted itself out somehow. I can now add the project. Not sure what changed.


#3

I just tried to add a new project in a different organization I am the owner of. There is only a single repo listed out of at least seven that should be shown. I tried using the python client for Github to make sure that the repos can be listed out:

import github
gh = github.Github(“kurtwheeler”, “REDACTED”)
user = gh.get_user()
for repo in user.get_repos():
… print(repo.full_name)

AlexsLemonade/AdminItems
AlexsLemonade/CCDL
AlexsLemonade/ccdl-hugo-template
AlexsLemonade/CCDLWebsite
AlexsLemonade/refinebio
AlexsLemonade/refinebio-design
AlexsLemonade/refinebio-landing
AlexsLemonade/scrum
AlexsLemonade/scrumlord

This makes it seem to me that it’s not an issue with Github, but with CircleCI code because you can see the difference between this list and the picture I have attached.:


#4

I suppose I should also note that the repo I am trying to add is not private: https://github.com/AlexsLemonade/refinebio-landing


#5

Hello?!? I cannot use your product because I can’t even select my repo. No response at all to what I would consider a critical bug? Do you even care that I can’t take the first step in your Setting up Your Build guide?


#6