Yarn still not working on image ruby:latest-node / ruby:latest-node-browsers still broken


#1

hey I saw you guys got fixes for node images for this yarn issue but it’s still not working on ruby:node-latest and I honestly don’t really know what to do.

#!/bin/bash -eo pipefail
bundle exec yarn install
bundler: failed to load command: yarn (/home/circleci/circleci-demo-ruby-rails/vendor/bundle/ruby/2.5.0/bin/yarn)
Gem::Exception: can’t find executable yarn for gem yarn. yarn is not currently included in the bundle, perhaps you meant to add it to your Gemfile?
/usr/local/lib/ruby/site_ruby/2.5.0/bundler/rubygems_integration.rb:458:in block in replace_bin_path' /usr/local/lib/ruby/site_ruby/2.5.0/bundler/rubygems_integration.rb:478:inblock in replace_bin_path’
/home/circleci/circleci-demo-ruby-rails/vendor/bundle/ruby/2.5.0/bin/yarn:23:in `<top (required)>’
Exited with code 1


#2

I’m also seeing this still:

#!/bin/bash -eo pipefail
yarn install
/bin/bash: yarn: command not found
Exited with code 127

For:

circleci/ruby:2.5.0-node-browsers


#3

See: Yarn missing from latest node 8 images?

The node guys pushed out a broken version today upstream that’s broken all kinds of stuff today. :frowning:


#4

yep I saw that before and was hoping for an update regarding the ruby-node-* tags. probably just have to wait :slight_smile:


#6

got my image working by adding apt-get install yarn to my list of run tasks and then make sure running yarn without bundle exec preceding it


#7