Xcode Project build failure....The file '.xcworkspace' was not found


#1

Hi Friends,

I am struggling to build Xocde project on CircleCI since last two days.

In my first try :

I have resolve third party API dependencies by CocoaPods. The github repo does not have the xcworkspace file of the project. But it should be created automatically when the command
(dependencies:
pre:

  • pod setup
  • pod install )

will be executed in circle.yml. But every time I am getting same error

(The file ‘.xcworkspace’ set for ‘XCODE_WORKSPACE’ was not found. This situation may cause errors if it is not auto-generated.)

Can anyone facing the same issue? Why ‘.xcworkspace’ file is not automatically generating on Circle CI side?

In Second try :

I have uploaded complete source code on github repo with all Pods. This time I have committed the ‘.xcworkspace’ file with source code. Now the error has changes and build still not got succeed.

Facing the error :


Check dependencies
Argument list too long: recursive header expansion failed at /Users/distiller/…-ios/…/.cocoapods/repos/master/Specs/AMGSoundManager.

  1 errored, 0 warning (1 ms)

Any once facing this type of errors and situation. Any help would be appreciated.

I hope Circle CI team will help me to fix this issue, I am struggling under this since last three days and made more then 40 commits on git to test or debug any change in circle.yml file.

Thanks!!!


#2