Xcode 8 - build failure

xcode

#1

I’m trying the brand-new support for XCode 8 that landed today in CircleCI.

From a build that had been working for at least a week, we got a sudden failure that seems to be happening right on the change to XCode 8.

We did the same command that has always worked:
gym --scheme Stardust --project ios/Stardust.xcodeproj --sdk iphoneos9.3 --use_legacy_build_api --buildlog_path $CIRCLE_ARTIFACTS

And we now get the error:
[18:04:07]: ▸ xcodebuild: error: SDK “iphoneos9.3” cannot be located.
xcodebuild: error: SDK “iphoneos9.3” cannot be located.
[18:04:07]: Exit status: 64

[!] Error building the application - see the log above


#2

Anybody had luck with XCode 8?


#3

It seems that the xcode8 image doesn’t have iOS 9.3 simulator. Just iOS 9.0 and iOS 10.0.
Try with a supported simulator.


#4

Thanks for the reply! I tried 10.0 and I got an error in my checkDependencies step, it’s just the generic “error 65” so I couldn’t troubleshoot.

Then I tried 9.0 and it says SDK not found. Are you sure 9.0 is in there?


#5

Hey everyone,

We have a simlink issue in our current image, therefore Xcode 8 only sees the iOS 10 simulators. It’s already on my list and we will fix this with a new version of the image very soon.

Cheers,
Constantin


#6

@anon47539524 any update? We’re totally blocked waiting for XCode 8 to work.


#7

No sorry, we have some overhead that’s required in order to verify our images and deploy them. If possible please return to Xcode 7.3.1 in order to build against the iOS 9 SDKs and runtime.

I will update you once the image it out.

Thanks,
Constantin


#8

Any update? It’s getting harder and harder to build with XCode 7.3.1. Is there an ETA for XCode 8?


#9