Workflows: job "build" not found

workflow
2.0

#1

Using the new 2.0 workflow scheme used to work, but now reports job "build" is not found; cf. https://circleci.com/gh/nschloe/meshio/97. Indeed there is no such job, but rather python2 and python3.


#2

Thanks for reporting this. It fails when a job is triggered by the API rather than from a source code commit. The first failed build was started from a settings change in our UI and the second was a rebuild. Both of these use the API to start a normal build - not a workflow.

We don’t currently have a way to start workflows via the API (which is what our UI uses to start a job) so clicking ‘rebuild’ won’t run the workflows. To do so, you need to go to the ‘workflows’ section of the UI and choose ‘rerun’. ‘rerun failed jobs’ or ‘rerun from beginning’.

I realise that’s a bit confusing! We’ll improve the UI around this during the rest of the Beta.


#3

Thanks for the reply. Indeed, it’s a bit confusing, but with your help I found the right buttons to click.


#4

FYI This also happens when the first build is triggered when adding a new repo (that contains a valid .circleci/config.yml file). When i did a fake commit, it worked.


#5

Does this mean using Workflows for automated CI tests, e.g. triggered by Phabricator will not work?


#6

+1 I have the same question. I’m assuming that triggering Workflows with Phabricator does not work.


#7

According to my conversation with support, that is correct. Hopefully they are working on it, as it is likely pretty darn common for us non-github users. I imagine for most Github-workflow uses who create a branch for each change, things just work.


#8

Does anyone know if this triggering workflow builds from forked PRs works now?


#9