URL for commit hash broken in pipelines (Bitbucket)

Bitbucket commit hash links in pipelines route to an invalid URL.

Links point to https://bitbucket.org/[repo]/commit/[hash]
The correct URL is https://bitbucket.org/[repo]/commits/[hash]


Thank you @Tearlach. I have passed this on directly to our team responsible for the new UI. We will look into this immediately.

[plus some characters to pass discourse’s length check]

Hi @uda! It looks like the issue was resolved on the workflows graph page, but not on the pipelines page. We’re looking into it right now!

Edit: It should be working now!

1 Like

It works now.

But I must know, you are serving developers, mostly, and this kind of issues have been solved and are usually taught in the first or second session of programming courses. use variables.
How come this issue was introduced, and why was this even open for so long, shouldn’t things like this be in the e2e testings?

From our end, it was a non-obvious bug in the UI code. We thought it was resolved earlier on and didn’t have any other reports of it until now. Thank you for reporting the bug so we could fix it!