Unexpected argument error when calling continuation pipeline

I have defined a parameter in config.yml

parameters:
  production-release:
    type: boolean
    default: false

and I have a workflow that is triggered only when parameter “production-release” is set (triggered via an API call)

The API call body:

    "branch": "release/1.0.0",
    "parameters": {
        "production-release": true
    }

When continuation occurs, the pipeline fails with the error:
Unexpected argument(s): production-release

It seems that parameters from the setup job are forwarded to the continuation.
In the continue_config.yml I don’t have the production-release parameter, if I have tried to put it, I got a “Conflicting pipeline parameters” error

1 Like

I’m having the same issue. Related?

Can you post more detail? Without the config.yml and continue_config.yml files it is very hard to tell what is going on. For now all I can say is that this post may help as it was dealing with the same error

@rit1010 check the solution from this discussion. Specifically, the manual-workflow-a and manual-workflow-b parameters have been defined in the continuation config even though they are not even used. Without duplicating them you would get the error “Unexpected argument(s)” highlighted by @kochax

Is this parameter forwarding the expected behaviour or is it a bug? If it’s expected it should be documented