How to pass pipeline parameters when using path filtering ORB

I want to trigger a pipeline using the pipeline API and i want to pass a pipeline parameter when calling the API. I was trying to simulate it using the CircleCI UI. the console has a button “Run Pipeline” and you can pass a parameter as an option. i passed a parameter defined in continue_config.yml but i got an error - “Unexpected argument(s): my-parameter”. We are using path filtering ORB. Could anyone let me know how to pass a parameter when using path filtering ORB?

Hi @sleegitus – welcome to Discuss!

Setup workflows are going to be a bit different when it comes to starting a pipeline with a parameter. The order of operations is the setup workflow first executes, then runs and essentially “continues” the next configuration file with any items specified in the setup workflow.

Because of this, if you don’t have the pipeline parameter specified at the top-level config file (your config.yml the one that executes your setup workflow) it won’t recognize the parameter. Can you try adjusting that, so the parameter is specified both in the continue_config.yml file and the config.yml file?

If the above doesn’t work please let me know and I can assist further!

-Nick

Thank you for responding. The secret is to define the parameters in both configs. After hurdling an error like “Conflicting pipeline parameters.”, I was finally able to pass a parameter. Thanks again.

1 Like

You’re welcome and glad to hear you were able to work it out!

If you have any other issues though let me know!

Hi sleegitus

How did you avoid the error “Conflicting pipeline parameters.”?

@sleegitus @nbialostosky Tagging you to get some attention and help :slight_smile:

Copying to both configs leads to conflicts like sleegitus mentioned.

I followed anothe thread here . But is there a simplere solution without continuation orb?

@srp-31 Are your pipeline parameters you set when triggering the pipeline named the same as those in your config? If so you’ll likely need to rename the other parameters by appending something like _continued or such so avoid a conflict.

If you’re still having issues and you have a specific example I’d be happy to take a look, or you can raise a support ticket so we can investigate further.