Trusty container update: 16.02.01


#1

Programming Languages

Python
Default: 2.7.11

Available versions

2.7.11
3.1.5
3.3.6
3.5.1
pypy-1.9
pypy-2.6.1
pypy-4.0.1

PHP
Default: 5.6.17

Available versions

5.5.31
5.6.17
7.0.2

Ruby
Default: 2.2.4

Available versions

default
ruby-2.0.0-p647
ruby-2.1.8
ruby-2.2.4
ruby-2.3.0

Nodejs
Default: 4.2.6

Available versions

v0.12.9
v4.0.0
v4.1.2
v4.2.6
v5.0.0
v5.1.1
v5.2.0
v5.4.1

Java

java version "1.8.0_40"
Java(TM) SE Runtime Environment (build 1.8.0_40-b26)
Java HotSpot(TM) 64-Bit Server VM (build 25.40-b25, mixed mode)

Go

1.5.2

Databases

MySQL

5.6.28

PostgreSQL

9.4.5

Redis

2:2.8.4-2

Elasticsearch

1.7.2

Docker

Docker

1.9.1

Docker Compose

1.5.2

Browsers

Firefox

44.0

Chrome

48.0.2564.97

PhantomJS

2.0.1-development

Misc

Qt

5.2.1

Memcached

1.4.0.rc2-1ubuntu1
1.4.14-0ubuntu9

RabbitMQ

3.2.4-1

PHP 7.0.2 Availability
#2

The bundler gem is not installed for Ruby 2.3.0 at least in the new image.


Trusty container update: 16.02.02
#3

I currently get Action failed: Configure the build on Ubuntu 14.04 (Trusty) container.


#4

Is this an open source project? If so can you give us the build URL?


#5

@FabianKoestring

Are you trying to use MongoDB? If so, it looks the service name has changed from mongodb to mongd on Trusty. We are now working on the fix. Sorry!


#6

@shaneog

Yup, already working on that. The easiest fix would be adding the following to your circle.yml.

dependencies:
  pre:
    - type bundle &>/dev/null || gem install bundler

#7

I just fixed bundler issue and rolled out the new image Trusty container update: 16.02.02


#8

I get following error right now. @kimh we use php7.0.2.

((phpenv global "7.0.2")) returned exit code 1
rbenv: version `7.0.2' not installed Action failed: set php version to 7.0.2

#9

@FabianKoestring How does your circle.yml look like?

It seems working for me: https://circleci.com/gh/kimh/trusty-test/60


#10
machine:
    php:
        version: 7.0.2
    timezone: Europe/Berlin

dependencies:
    pre:
        - sudo composer self-update
        - php -v
        - mysql -V
        - sed -i 's/^;//' ~/.phpenv/versions/$(phpenv global)/etc/conf.d/xdebug.ini
    override:
        - composer install --no-interaction
checkout:
    post:
        - git submodule sync
        - git submodule update --init

#11

@FabianKoestring Although I can’t reproduce the exact error, I can see a thing that will not work on new Trusty image.

We install .phpenv and other (*vm and *env) under /opt/circleci, so can you change it to the following?

- sed -i 's/^;//' /opt/circleci/.phpenv/versions/$(phpenv global)/etc/conf.d/xdebug.ini

#12

Ok. Running lsb_release -a returns

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 12.04.5 LTS
Release:        12.04
Codename:       precise

Expiremental setting Ubuntu 14.04 Trusty container is set to true.


#13

That’s very strange. Maybe you haven’t trigger a new build by pushing to Github after changing to 14.04 (rebuilding will trigger a build with old setting) ?


#14

Yea you was right. I had a pr open on github and triggerd it. Now i created a new one and everything works as expected.

@kimh thanks for helping me out.


#15

I am having connecting to docker daemon on the Trusty containers. Is there a trick I am missing?

ubuntu@box69:~$ docker ps
Cannot connect to the Docker daemon. Is the docker daemon running on this host?
ubuntu@box69:~$ docker daemon
FATA[0000] Error starting daemon: open /var/run/docker.pid: permission denied

Trusty container update: 16.02.03
#16

Memcache appears to be installed on Trusty image, but is it started?


#17

@tjchambers Sorry, I need to document this but we like to keep our default services as few as possible. This will give us many advantages such as more free memory for builds.

You can start memcached with the following circle.yml.

machines:
  services:
    - memcached

#18

@jesh Sorry about that! This should be fixed now: Trusty container update: 16.02.03


#19

Hi,

it looks like the new image is missing the PostGIS support.

ERROR: could not open extension control file “/usr/share/postgresql/9.4/extension/postgis.control”: No such file or directory
ERROR: could not open extension control file “/usr/share/postgresql/9.4/extension/postgis_topology.control”: No such file or directory
ERROR: could not open extension control file “/usr/share/postgresql/9.4/extension/postgis_tiger_geocoder.control”: No such file or directory

To replicate this, simply run the following commands in the postgres prompt:

CREATE EXTENSION postgis;
CREATE EXTENSION postgis_topology;
CREATE EXTENSION postgis_tiger_geocoder;

#20

@dlsniper Thanks for bringing this up. I’ll add PostGIS/GEOS support.