Strange behavior with Docker-Compose version

Hello everyone!

Since last week, I’ve met a strange behavior when using docker-compose for a job dedicated to integration tests.

For some months now, our docker-compose.yml dedicated to this job was in version 2.4 and run perfectly, however (since last week) the job crashes with a message that says that our docker-compose version isn’t supported. I didn’t see any announcement from CircleCI regarding an update of the remote_docker default version but okay. :thinking:

So, I try to add the following to the relevant steps in our config.yml file:

- setup_remote_docker:
  version: 18.05.0-ce

but it didn’t change anything.

Is anyone facing a similar issue at this moment? Maybe I did something wrong when adding the setup_remote_docker in the file but it worked before and I don’t know why it didn’t work now without an update in our side. :exploding_head:

Do you, folks, know something about that?

Are you using the Docker executor or the Machine executor? If you are using the former, what parent image are you using for the build? You can certainly specify exact versions of Docker and Docker Compose in this executor.


I’ve tried both and the error appears in both cases.

I checked the version of docker and docker-compose running in the job (through ssh) and everything seems fine.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.