SSH no longer works

I am unable to SSH into containers (but can push to github via my ssh key just fine).

I have verified the public key in github is the pair of the private key trying to use locally. Have even specified the identity file directly in the ssh command with -i /path/to/privatekey

Circle-CI server keeps responding with Permission denied (publickey)

1 Like

Same. Worked fine before, hasn’t worked for past month.

ssh indicates authentication is fine.

1 Like

I changed my SSH key in Github and circleci was unable to deal (somehow) with my new ssh key, although I could still interact with github via it. My new key is ED25519 whereas my old one was an RSA key? Even when I specifically referenced the private key in the ssh command it would reject it

When I re-uploaded my RSA key to github, I was able to ssh into circleci again. But this a kind of poor solution, tbh

1 Like

Ah, found the cause. The project is owned by another Github account (which I also control). Something must have changed with Circle as it seems to only allow the project owner to ssh in now.

I fixed it by generating a new ssh key for the project owner (ssh-keygen -f ~/.ssh/other), adding it to Github, and using that to connect to Circle (ssh -i ~/.ssh/other).

Having the same issue, and its been that way for several months. I also tried creating new SSH keys but no go.

This makes debugging stuff a LOT harder… ):

ECDSA and DSA keys work as well.
Just not ED25519