Specifying Xcode=6.3.1 failing, is this version deprecated?


#1

Our iOS builds specify Xcode version 6.3.1, but are failing due to not finding it – is it not supported any more? (Docs say it’s default.)

sudo xcode-select --switch /Applications/Xcode-6.3.1.app

sudo xcode-select --switch /Applications/Xcode-6.3.1.app returned exit code 1

xcode-select: error: invalid developer directory ‘/Applications/Xcode-6.3.1.app’ Action failed: Select Xcode Version


#2

Hi there,

In order to specify an Xcode version, you’ll want to wrap the version number in quotes. The error you’re seeing occurs when the version number is not wrapped in quotes. Can you try specifying the Xcode version in your circle.yml like so?

machine:
  xcode:
    version: "6.3.1"

If this solves your problem, please mark this as the solution by clicking on the checkbox below.

Cheers,
Frank

EDIT: As indicated below, Xcode 6.3.1 is no longer supported. Sorry for any confusion.


#3

Yep, our circle.yml starts like:

machine:
  xcode:
    version: "6.3.1"

One of my teammates got a notification message, though, that Xcode versions were being upgraded – 6.4 is the new default and 6.3.1 is no longer supported. Sounds like that is the issue.


#4

Oops! It looks like you’re right.

I tried running a build with and without quotes on my test project and falsely attributed the cause of the error to the quotes. The real reason why one build worked and the other didn’t is because we’re still in the process of upgrading our fleet and 6.3.1 is still supported on some machines.

Sorry for the confusion!


#5