Specifying Node version for docker image ruby:2.3-node


#1

We are using Ruby on Rails with ember-cli and have an older version of Node (6.10). How can you specify the Node version for the Docker image to use? I didn’t find anything in the docs, so I’m assuming that I will need to manually install the version of Node I want to use.


#2

Not sure if there’s a better way to do it, but we use the NodeSource distributions (https://github.com/nodesource/distributions) to install a specific version of Node on Ubuntu:

curl -sL https://deb.nodesource.com/setup_6.x | sudo -E bash -
sudo apt-get install -y nodejs

#3