Specify cocoapods version


#1

I was previously shown by circle support how to specify the version of cocoapods for my build, using the following syntax in dependencies -> pre of circle.yml:

- sudo gem uninstall cocoapods -v 0.39.0
- pod --version # 0.38.2

It was working fine until recently. Now the builds time out with the following output:

sudo gem uninstall cocoapods -v 0.39.0
You have requested to uninstall the gem:
cocoapods-0.39.0

cocoapods-check-0.1.0 depends on cocoapods (~> 0.39.0)
If you remove this gem, these dependencies will not be met.

Continue with Uninstall? [yN] command sudo gem uninstall cocoapods -v 0.39.0 took more than 10 minutes since last output

I started to try to hack through this but I was wondering if there is a better way to specify the cocoapods version installed?


#2

Sorry about that! You’ll need to add --force flag to the gem uninstall cocoapods command.


#3