Ruby 2.3.0


#1

I just made Ruby 2.3.0 and pushed to our download place.

You can use it by putting the following machine section in your circle.yml.

machine:
  ruby:
    version: 2.3.0

  pre:
    - wget https://s3.amazonaws.com/circle-downloads/circleci-ruby2.3.0_0.0.1_amd64.deb
    - sudo dpkg -i circleci-ruby2.3.0_0.0.1_amd64.deb

Working demo: https://circleci.com/gh/kimh/circleci-playground/41


#2

Thank you kimn for this. But unfortunately I got this error:

/home/ubuntu/.rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/rubygems/dependency.rb:319:in `to_specs’: Could not find ‘bundler’ (>= 0.a) among 5 total gem(s) (Gem::LoadError)

Do I need to do gem install bundler first?


#3

Do I need to do gem install bundler first?

Sorry, looks bundler is missing in the package. Could you workaround by installing bundler? I can re-create the package including bundler soon.


#4

Hey, did you add bundler to the package? :slight_smile:

Getting this error on my end:

$ gem install bundler
ERROR:  Loading command: install (LoadError)
	/lib/x86_64-linux-gnu/libcrypto.so.1.0.0: version `OPENSSL_1.0.1d' not found (required by /home/ubuntu/.rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/x86_64-linux/openssl.so) - /home/ubuntu/.rvm/rubies/ruby-2.3.0/lib/ruby/2.3.0/x86_64-linux/openssl.so
ERROR:  While executing gem ... (NoMethodError)

gem install bundler returned exit code 1

undefined method `invoke_with_build_args' for nil:NilClass Action failed: gem install bundler

#5

Ben, I also get that error too.


#6

I get the same error too. This just happened in my builds.


#7

Sorry guys. I’ll rebuild the package by the end of my day (JST :japan:)


#8

seems to work now, maybe it was just an issue of downloading deps


#9

Sorry guys. I fixed the package. Unfortunately, I found that we still need to install bundler :frowning:

The following circle.yml should work.

machine:
  ruby:
    version: 2.3.0

  pre:
    - wget https://s3.amazonaws.com/circle-downloads/circleci-ruby2.3.0_0.0.1_amd64.deb
    - sudo dpkg -i circleci-ruby2.3.0_0.0.1_amd64.deb

dependencies:
  pre:
    - gem install bundler

Working demo: https://circleci.com/gh/kimh/circleci-playground/44#config


#10

I got it to work by removing the explicit declaration. Through circle’s inference, I was able to run a build for my app that uses ruby 2.3.0. I guess this is different from natively supporting it


#11

When will Ruby 2.3 be added to the standard image?


#12

Forgive my ignorance; why is this needed more than just specifying the ruby version? I only specified the version and CircleCI took care of installing it.

That being said—like others here—I want to know when 2.3.x will be pre-installed.


#13

I thought CircleCI used RVM for ruby? 2.3 is available via rvm. Downloading a specific .deb may work, but builds would start breaking when the .deb updates.


#14