PR is not triggering builds

Prior PR’s triggered builds just fine. Today, this PR is not triggering a CircleCI build, and I can’t figure out why:

I tried re-delivering a couple of webhook events, but still no build is triggering (and CircleCI no longer shows under the list of “checks” to be performed.


Hi @bhamail

There are a few common things we can check first.

If you revoked OAuth access to CircleCI on your VCS provider (GitHub, BitBucket)

If you’re following the fork instead of the upstream repo

If the branch and the pull request happen to be created simultaneously

There’s a bit more detail in this article around each of these causes. If none of these seem to be the cause, we can explore more options!

Hi @thekatertot ,
Thanks for the quick reply. I verified the DeployKey is still in place. Another build just ran successfully today, and I haven’t twiddled with anything on the CircleCI side.

This PR is from a branch in the same repo, not a fork.

Simultaneously triggered race conditions - I don’t think so because “Only build pull requests” is disabled.

Unless I’ve missed something, I think we need to explore more.

1 Like

Hi @bhamail,

Is the issue resolved?

We faced the similar thing in our project repos few days back and it was resolved automatically.