Please specify a valid 'path_to_lcov' parameter for coveralls orb

I keep getting error Please specify a valid 'path_to_lcov' parameter., but I am not sure what exactly means. The documentation mentions path_to_lcov is default to .coverage. I believe my coverage report file name is .coverage.

Below is my config file

version: 2.1

orbs:
  coveralls: coveralls/coveralls@1.0.6

jobs:
  build-and-test:
    machine:
      image: ubuntu-1604:202007-01
    steps:
      - checkout          

      - run:
          name: Before Install
          command: |
            sh script/install/before_install.sh
            sudo apt-get install -y npm
          environment:
            DEBIAN_FRONTEND: noninteractive

      - run:
          name: Install
          command: | 
            export PATH="$HOME/miniconda/bin:$PATH"
            sh script/install/install.sh
            # allow no-password connection for root
            sudo mysql -u root -e "SELECT User,Host FROM mysql.user; 
                                   DROP USER 'root'@'localhost'; 
                                   CREATE USER 'root'@'%' IDENTIFIED BY ''; 
                                   GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' WITH GRANT OPTION; 
                                   FLUSH PRIVILEGES;" 
      - run:
          name: Test
          command: | 
            export PATH="$HOME/miniconda/bin:$PATH"
            conda init bash
            source ~/.bashrc
            conda activate eva
            sh script/test/test.sh # here it uses pytest to generate coverage report
      - coveralls/upload
      
workflows:
  main:
    jobs:
      - build-and-test

The coveralls orb upload command takes in a parameter path_to_lcov. This would be the local path to the lcov output file produced by your test suite.

You’ll want to explictly set that value to where sh script/test/test.sh outputs the coverage report:

- coveralls/upload:
    path_to_lcov: /path/to/coverage/files/changeme