No available formula with the name "android-sdk"

android

#1

https://circleci.com/gh/crossroads/admin.goodcity/2458

brew install android-sdk
Error: No available formula with the name “android-sdk”

previous builds were able to install android-sdk but today all of the sudden i start getting this error. CirclecCi is deteriorating day by day.

Tried rebuilding without cache and still doesn’t work.


#2

Getting the same error


#3

From the build failure step:

==> Searching taps...
This formula was found in a tap:
Caskroom/cask/android-sdk
To install it, run:
  brew install Caskroom/cask/android-sdk

It looks like Homebrew changed how they package Android SDK, and you’ll have to run brew install Caskroom/cask/android-sdk.


#4

Oh thanks Eric, that was really helpful.


#5

Hi Eric,
I have updated caskroom changes and now i am getting this error, could you help me with this?
https://circleci.com/gh/crossroads/stock.goodcity/1198


#6

Hey there. A couple of things.

  1. We don’t “officially” support running android builds on our MacOS machines so your mileage may very.
  2. Same goes for Fastlane, we don’t officially support doing this.

I would recommend starting a new topic to troubleshoot the fast lane errors since the original issue of not being able to install the android SDK was already resolved. We don’t have any insight to this but perhaps someone else in our community has run into this before.


#7

Just for future reference (in case it helps anyone on a google search), I was able to install the Android SDK using the following circle.yml snippet. This caches the SDK so it doesn’t need to be re-installed with every build run.

machine:
    ANDROID_HOME: "${HOME}/android-sdk"
    PATH: "${PATH}:${ANDROID_HOME}/tools"

dependencies:
  cache_directories:
    - ~/android-sdk
  pre:
    - mkdir -p ${ANDROID_HOME}
    - if ! $(grep -q "Revision=23.0.1" ${ANDROID_HOME}/tools/source.properties); then (curl -o ~/android-sdk.zip https://dl.google.com/android/repository/tools_r23.0.1-macosx.zip && unzip -d ${ANDROID_HOME} ~/android-sdk.zip) && (( sleep 5 && while [ 1 ]; do sleep 1; echo y; done ) | android update sdk --no-ui --all --filter platform-tools,build-tools-23.0.1,android-23,extra-android-m2repository,extra-google-m2repository); fi

#8