New free plan with more premium features!

Hello everyone!

Today we are officially launching our new free plan. The new and improved free plan now includes private orbs, self-hosted runner, flaky test detection, Docker Layer Caching, and upgraded resource classes for all executors. It also includes a concurrency limit of 30 (upgraded from 1). We want our free offering to be the best any developer can get, period. Check out our announcement post and ask any questions you have in this thread!

7 Likes

would be nice if there was a very simple way to use concurrency with rspec

1 Like

Thanks, 30 concurrent jobs are really generous for a free plan.

1 Like

@dorianmariefr I’d love some more insight into where the sticking points are with rspec. Is there something in particular that’s difficult or just in general?

1 Like

Hi,

  • I can’t run circleci tests glob locally because it requires circleci-agent
  • tried on my builds in a separate branch
  • for some reasons nothing was echoing, so had to ssh into the branch
  • ok so circleci tests glob "spec/**/*_spec.rb" was right
  • for some reason the same command was running fine on the SSH server but not in the job (returned 0 results)
  • ok my mistake, my repo was not checked out when I was trying to get the files
  • ok got it working, was not too hard
2 Likes

But with parallelism 10 I get 5 minutes builds instead of 3 minutes 30 seconds builds

seems like 3 minutes are spent booting up the postgres and redis containers

1 Like

Good to know! I will definitely get some of our team to take a look and see if we have any recommendations or improvements we can make on our end.

Hello,

A new free plan include Docker Layer Caching , but a testing with a build log on
- setup_remote_docker:
docker_layer_caching: true

Allocating a remote Docker Engine
Requesting version: default
Specified using docker layer caching, but it is only available for Performance Plan.
Upgrade to Performance Plan to use docker layer caching.

Is there anything to do?

Thanks

1 Like

Hey @mysolo Thanks for your patience! Is this still happening? You should be able to run DLC on the free plan with the config set to true.

Hi, the message

Specified using docker layer caching, but it is only available for Performance Plan.
Upgrade to Performance Plan to use docker layer caching.

Still shows up in the build log when using the free plan with docker_layer_caching: true

My account was only set up a day or 2 ago, so this is an ongoing issue.

1 Like

I’m on the free tier and despite having docker layer caching enabled in my config.yml, I still get the message:

Allocating a remote Docker Engine
Requesting version: 20.10.11
Specified using docker layer caching, but it is only available for Performance Plan.
Upgrade to Performance Plan to use docker layer caching.

Any suggestions on what to do? Would love to try this out.

You need to send a message to the support team as it seems that accounts have been set up with both this feature and the right to run self-hosted runners are still disabled.

I had the same problem and it took a day or 2 to resolve.

1 Like

Hi everyone! You should not need to open a Support ticket to have access to Docker Layer Caching on the free plan. It should be available by default. If you have problems, you should definitely let us know so we can fix it.

Well having posted the issue here (see a few messages back). I contacted support and they fixed an issue with my account that was created about a month ago. As part of the email reply, the following was stated.

“There are some cases where the features are not enabled by default due to a bug on our end. I have enabled Docker Layer Caching and Runners”.

1 Like

Thanks for the clarification @rit1010! This should be a small subset of folks affected by this bug, but you should definitely contact support if you see it. :smiley: