My Project build process taking too much time , i am not seeing build success message


#1

How to find root cause error.

This is my project public URL.


#2

To simplify the debugging process, please post the following about the issue you are seeing:

  • The stack you are using
  • The most relevant lines of the error message
  • The expected output / behavior
  • Any changes you have made to your CircleCI setup recently
  • Whether the tests pass locally or not
  • The steps you have tried while attempting to fix the issue
  • A link to the build URL if this is a public project

Thanks.


#3

Thank you for response , here its taking long time.

I have already posted public url of my project.

TESTS

Running org.apache.commons.csv.CSVFormatTest
Running org.apache.commons.csv.CSVFormatTest…


#4

The error message in this build is:

command ((mvn "integration-test")) took more than 120 minutes to run

We currently don’t allow running build commands that take longer than 120 minutes to execute, for security reasons. Sorry about that!

Are you sure the tests should be taking that long? Would it be possible to divide the tests between multiple build commands?

Thanks.


#5

I believe what you want is

test:
  override:
    - mvn clean package

mvn integration-test seems to do a LOT of extra steps and run over that limit

I’m not sure which steps Circle runs by inferred, I know I’ve run onto issues with integration-test the few times I’ve tried java.

ref: https://commons.apache.org/proper/commons-csv/


#6

HI drazisil,

Thank you so much…its working fine…you are right, its need mvn clean package.


#7

i need one more help…

https://github.com/rchennuri/podam , this url is public.

The build was success , but i am unable to see test results on test results tab.

Please help me on this.

Thanks.


#8

#9

Thank you for your time.


#11

I wonder why I still cant see the “Test Tab Result” still not showing up in my envirnment


#12

Hello i need help with this AS WELL. Did u get the answer please?


#13

This solution is still not working for me.Could you please help.


#14
test:
 post:
   - mkdir -p $CIRCLE_TEST_REPORTS/junit/
   - find . -type f -regex ".*/target/surefire-reports/.*xml" -exec cp {} $CIRCLE_TEST_REPORTS/junit/ \;
test:
  override:
    - mvn clean package

You have two test sections. I believe based on that it is running the full test suite. It should look like this:

test:
  override:
    - mvn clean package
  post:
    - mkdir -p $CIRCLE_TEST_REPORTS/junit/
    - find . -type f -regex ".*/target/surefire-reports/.*xml" -exec cp {} $CIRCLE_TEST_REPORTS/junit/ \;

#15

I am facing the same issue.I tried the above solution.It is in the $ mvn clean package stage.Plz help


#16

Hi,

I am also facing the same issue.The build is taking a long time.I added mvn clean package also.Still its not working


#17

Can you help with this issue?My project is at https://github.com/srivathsani/commons-csv


#18

Any solution to this problem, I having the same issue.
my circle.yml is:
test:
override:
- mvn clean package
post:

  • mkdir -p $CIRCLE_TEST_REPORTS/junit/
  • find . -type f -regex “.*/target/surefire-reports/.*xml” -exec cp {} $CIRCLE_TEST_REPORTS/junit/ ;

#19