Must have admin permission

I need to create big amount of secrets. I don’t want to do it manually, so I’m trying to work with contexts using CircleCI CLI.
I’m not administrator in organization, but I can store and remove secrets from UI.
But when I’m trying to do it fro CLI I have:

dkurilo@Chth0n$ printf "bar" | circleci context store-secret GITHUB <my-org> <my-context> foo
Error: failed to load context list: Non-nullable field was null.
Must have admin permission.

I have the same error when I’m trying to get list of context (I see list from UI).
Is it bug or feature?

Hello @DKurilo - Welcome to the CircleCI community!

I have encountered this same error when I rotate Personal API Tokens and forget to update my token.

You must first visit Account Settings ( and add a Personal API Token.

After that, in the CircleCI CLI, run circleci setup to enter your personal API token.


Just to note, I am using the CircleCI CLI version: 0.1.7179+e661c13

See if this works for you. If not, please do reach out and submit a Support Ticket here:

Hey @JonathanC503,
Thank you for your answer.
I have circleci version: 0.1.7031+6da924f
After I was given admin permission it starts working.
I updated circleci CLI version, but I’m not able to test it right now (because I have admin permission and don’t want to remove it right now).
Maybe I’ll try it later.