macOS: circle command vs SSH debugging

ios
circle.yml
macos

#1

Hi,

we are successfully running build scripts for cordova apps for iOS, however today ran into a weird problem with a new project while trying to add the ios platform.

Our command looks like this:
cd cordova && cordova platform add ios

and we get following error:
Error: Your ionic-plugin-keyboard platform does not have Api.js

The weird thing is, when debugging over SSH we can call the same command and it works without problems.

We also tried to pack the commands into a shell script (being paranoic) with the same results:

Not sure what the real issue here is, any ideas are welcome, thanks.


#2

Okay, it was stuff in package.json/config.xml left from local commits with ios platform installed. After first fail the second platform add worked. There the solution was to first run remove and then add with specific version number:
cd cordova && cordova platform rm ios && cordova platform add ios@4.5.1


#3

Hi there,

I’m glad that you found the solution to your problem.

Would there have been a way that we could have detected this earlier in the process for you do you think?

Marc


#4