Licences for Android SDK not accepted


#1

Seems like something’s not right with most recent build tools:

FAILURE: Build failed with an exception.

* What went wrong:
A problem occurred configuring project ':app'.
> Failed to install the following Android SDK packages as some licences have not been accepted.
 platforms;android-28 Android SDK Platform 28
  To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
  Alternatively, to transfer the license agreements from one workstation to another, see http://d.android.com/r/studio-ui/export-licenses.html
  
  Using Android SDK: /opt/android/sdk

This happens when trying to run ./gradlew lint

Already checked this topic: Licences for Android build tools not accepted
This seems to be a new problem.


Build fails since image `circleci/android:api-28` has been updated!
#2

Hey there! I also started getting the same error today. In my case I needed to update the Docker image used during builds from circleci/android:api-27-node8-alpha to circleci/android:api-28-node8-alpha


#3

That’s true, also in my case, updating the docker image from circleci/android:api-27-alpha to circleci/android:api-28-alpha solved the problem.

Thank you for your answer.


#4

I faced the same issue here


#5

Confirmed it’s working!
I can deploy my React Native application to the store :raised_hands:

@IslamSalah Here is an example if it’s not working for you.
image


#6

Hi All! More information on how Android images are now updated and how to remedy this issue can be found in this post.


closed #7

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.