Android SDK Platform 23 license not accepted

android
react
#1

Hello there!

I recently bumped to React Native 0.59.5

Diclamer: I already tried this solution and it’s not working

My issue is: I need to accept the android-23 Android SDK Platform 23.

* What went wrong:
A problem occurred configuring project ':react-native-branch'.
> Failed to install the following Android SDK packages as some licences have not been accepted.
     platforms;android-23 Android SDK Platform 23
  To build this project, accept the SDK license agreements and install the missing components using the Android Studio SDK Manager.
  Alternatively, to transfer the license agreements from one workstation to another, see http://d.android.com/r/studio-ui/export-licenses.html
  
  Using Android SDK: /opt/android/sdk

Does anyone have an idea why?

#2

How did you accept the license agreement before? If there has been a change (as a result of upgrading React Native) is there anything about that on the appropriate issues list at GitHub?

#3

@halfer Last time I bumped the docker image


and it worked

I tried to change the image to

    docker:
      - image: circleci/android:api-28-node8-alpha
      + image: circleci/android:api-28

But I have another problem because yarn is not installed :sob:

#4

So install it? :grinning:

I assume that just requires an apt-get install or similar.

#5

It works with

    docker:
      - image: circleci/android:api-28-node

I forgot the -node :sweat_smile:

2 Likes
closed #6

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.