Jq issue since 7 september

Hello everyone!
Since yesterday I have been getting this error:

A different version of jq is installed (jq-1.6); removing it curl: (3) URL using bad/illegal format or missing URL Exited with code exit status 3

I am using the latest version of jq orb circleci/jq@2.2.1


This thread covers the same issue.

Thank you for your reply.
Yes, I saw it. They say the issue has been solved but I am still having the same issue.

Can you provide more details about your environment?

circleci/jq@2.2.1 has been updated to handle the new home for jq and the jq repo was updated yesterday to correctly provide a jq-linux64 file.

The thing is that without more info about your environment, it is not possible to tell if it is the Linux version that your workflow is trying to retrieve.

The environment is a docker image cimg/python:3.9.4 which is using a Linux system.

In the jq install error when I clicked on see more I saw that JQ_SOURCE_URL and JQ_BINARY_URL were referring to the old repo

I’m facing the same error.
The environment is a docker image ‘cimg/python:3.9-node’ which is using a Linux system.
It gets triggered when I use the jira/notify orb commands

It was the same for me, Use jq: circleci/jq@2.2.1 and before the Jira notification command run this:

- jq/install:
              override: true
              version: "jq-1.7"

Yes it worked for me now! Thanks a lot!! :slightly_smiling_face:

You are welcome!