Installing pyenv on rhel arm64 yields command not found

I have been trying to setup a self-host runner on AWS using RHEL9 image.
I have installed the runner on the instance. Checked if the service was running and it was.
Then install pyenv on the machine under the circleci user, added the necessary exports to .bash_profle and .bashrc, but when I run the command I get pyenv command not found.
I tried adding the exports to $BASH_ENV but then I get a warning that shell level is too high reseting to 1. After that I get some cannot allocate memory errors and the workflow is killed. Here is one of the jobs that throws this error. Job
SSH-ing into the instance and trying the command under the circleci user works perfectly.
Where else do I have to install pyenv in order for the terminal to recognize the command?
Thank you for your time.
Have a wonderful day

Manged to fix it.
When adding the export to $BASH_ENV I omitted the eval command.
Seems to be working now

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.