Install iOS 13.2 Simulator in Xcode 11.3 Image?

We’re as of yet unable to use the Xcode 11.3 image due to a known issue that prevents XCTest from automating webview text fields, hence breaking our UI test suite. This has been reported by others and is a known issue, although it’s unclear if it’s one Apple is addressing.

A reliable workaround for this issue is to use iOS 13.2 simulators instead of iOS 13.3. The problem being: 13.2 isn’t presently installed in the Xcode 11.3 image. Any chance it could be, at least until we’re able to confirm the issue has been addressed by Apple (likely in a future Xcode release)?

The xcode-install gem is installed on the images for the system Ruby. You should be able to install 13.2 with the following:

xcversion simulators --install='iOS 13.2'

I’ve not tried this out, so you might been to play around with the command to get it to work.

Aha - I had tried adding xcode-install to my project’s bundle and running that command via bundle exec but it asked for machine credentials to complete the install. I will try using the non-bundled version and see if that makes a difference.

Here is the result when I do that:

static:~ distiller$ xcversion simulators --install='iOS 13.2'
Installing iOS 13.2 Simulator for Xcode 11.3.0...
100 3106M  100 3106M    0     0  82.4M      0  0:00:37  0:00:37 --:--:--  103M%
%Mounting DMG
Expanding pkg
Expanded pkg into /Users/distiller/Library/Caches/XcodeInstall/
Unmounting DMG
Setting package installation location
Rebuilding package
Please authenticate to install iOS 13.2 Simulator...

Ok I’m wrong…it does throw up the “Please authenticate” and appears to hang…but it does eventually succeed with the install. I’ll move forward with that workaround and see if it helps unblock.