Image circleci/php:5.6-apache-node doesn't work anymore

Latest image circleci/php:5.6.38-apache-node doesn’t work i got this error (locally & on circleci) :
docker: Error response from daemon: linux spec user: unable to find user circleci: no matching entries in passwd file.
ERRO[0001] error waiting for container: context canceled

Previous one (circleci/php:5.6.37-apache-node) work well


I’m getting the exact same error same error with circleci/php:7.2-node as of today.

I’m also experiencing this with circleci/php:7.2-node

Seeing this on ruby:2.5-node as well. Image was updated 30 minutes ago. Is this issue affecting all of the “-node” variant images?

Getting this as well with python 3.6-node

If you’re blocked on this, you can reference an older docker image by sha256 hash in the circleci config.yml. E.g.: last working ruby:2.5-node image is: circleci/ruby@sha256:55e6eec5d67fc22d4ad3aba19cc092e0b0fd06ad26196d6adaa012abcf1d7dcd

Hope the current tag gets fixed soon though.

1 Like

I have had the same in an open source project (elastipath/fonda).

Digest: sha256:df897cc7b810bab2364a80b0752935412e79de0073a041cb68bbf2f0a31784f8
Status: Downloaded newer image for circleci/clojure:lein-2.8.1-node
  using image circleci/clojure@sha256:df897cc7b810bab2364a80b0752935412e79de0073a041cb68bbf2f0a31784f8

Error response from daemon: linux spec user: unable to find user circleci: no matching entries in passwd file

Is there a way to get the sha256 of an old working image? Kind of new to this :smile:

I got the hash from a previous successful CircleCI build. If you expand the “Spin Up Environment” step at the beginning you’ll see something like:

Status: Image is up to date for circleci/ruby:2.5-node
  using image circleci/ruby@sha256:55e6eec5d67fc22d4ad3aba19cc092e0b0fd06ad26196d6adaa012abcf1d7dcd
1 Like

Same on open jdk images

Same issue on circleci/python:3.5-node circleci/python@sha256:1e975f2bd659628e30b148a207a8950361754da5c4519b529886cd24be1e8623

Hi All! We are currently investigating this and working on a resolution. During the interim, you can pin the image to a previously working sha. More information on this can be found on this post: Docker images unable to find circleci user

Thank you! That worked like a charm!

This issue has been fully resolved at this time.