Illegal instruction (Core Dump) on python

python

#1

Hi all,

I don’t know if this is the correct place where to put my request.
I’m facing an issue while building a python application which requires reading a HDF database with pandas and pyTables.

When opening a hd5 files and using its content, the python app return Illegal Operation (core dump)
I’ve tried to debug using SSH, but I was not able to get more insight.

I was not able to read the dumped core because /proc/sys/kernel/core_pattern is not modifable even if I sudo and it still uses apport

I’ve tried to create the environment(ubuntu 14:04, python3.6, same pyTables, Pandas version) on an AWS EC2 instance and everything is fine.

All our local machine are able to run the tests or read from the same hd5 test file

I’ve tried to use the docker image circleci/build-image to replicate the environment but I’m not able to run /bin/bash on it

Anyone ever faced the same/similar issues?


#2

@tom or @bear any ideas here?


#3

Thanks for your question. Can you confirm if you’re running this on CircleCI 1.0 or 2.0?

If it’s a new project it could be worth trying on 2.0 - https://circleci.com/docs/2.0/

Let us know any additional information you can share and we’ll see if we can get to the bottom of this.


#4

Hi Tom,
I’m using Circleci 1.0. I might try the 2.0 as soon as I’ll go back to that task.
I’ll keep you posted!

thanks!


#5

We think it’s likely that the dependencies are failing to compile within our build environment. If you’re able to share your build output logs it might help us diagnose what the issue is. Feel free to send me a DM if that’s a good way to share the info.


#6

Hi all,
I was able to go back to that problem, and yes I confirm what @tom said: it was one of our dependency that was failing to build 'cause it was expecting some .c headers not available in the env.

We replicate our environment, adding downloading and installing anaconda before doing anything pip related and that fixed the problem.


#7