I think my fastlane build is trying to ask a question on the console. How do i find out?


#1

I’ve got an iOS build that has been happily running whenever we push to a particular git branch. We just upgraded to XCode9, and when I did the same in circleci, the build hangs when trying to sign an app extension

I’ve verified that the provisioning profiles and certificates are valid (they’re the ones we use in development). However the build always hangs during signing:

INFO [2017-10-18 12:01:23.01]: ▸ Compiling MainInterface.storyboard
INFO [2017-10-18 12:01:27.54]: ▸ Processing Info.plist
INFO [2017-10-18 12:01:27.56]: ▸ Generating 'ImessageExtension.appex.dSYM’
INFO [2017-10-18 12:01:27.68]: ▸ Running script '[CP] Copy Pods Resources’
INFO [2017-10-18 12:01:31.79]: ▸ Touching ImessageExtension.appex
INFO [2017-10-18 12:01:33.96]: ▸ Signing /Users/distiller/Library/Developer/Xcode/DerivedData/company-aqtngtvmjobmrfgiexeqvibhsmyr/Build/Intermediates.noindex/ArchiveIntermediates/CI_Build/IntermediateBuildFilesPath/UninstalledProducts/iphoneos/ImessageExtension.appex

If i look at the log in /tmp/circle-artifacts/gym, the hang happens here:

/usr/bin/codesign --force --sign B60402E90475F266E93C50B8A44327C8F45F6445 --entitlements /Users/distiller/Library/Developer/Xcode/DerivedData/company-aqtngtvmjobmrfgiexeqvibhsmyr/Build/Intermediates.noindex/ArchiveIntermediates/CI_Build/IntermediateBuildFilesPath/company.build/CI_Release-iphoneos/ImessageExtension.build/ImessageExtension.appex.xcent --timestamp=none /Users/distiller/Library/Developer/Xcode/DerivedData/company-aqtngtvmjobmrfgiexeqvibhsmyr/Build/Intermediates.noindex/ArchiveIntermediates/CI_Build/IntermediateBuildFilesPath/UninstalledProducts/iphoneos/ImessageExtension.appex

If i try to execute this command on the command line, it also hangs. This feels like some password isn’t being setup correctly, so a dialog box is prompting for a password on the console.

Is there a way to get VNC access to the console to check? I tried ssh forwarding to port 5901, but it has a password and I’m not sure what that is.

Thanks.


#2

Hey there! Have you been able to find out what’s happening here? I’m having exactly the same issue after moving my working fastlane setup to CircleCI 2.0: Issues with code signing on CircleCI 2.0


#3

Yes, i was having a keychain issue where a question was being asked on the console. I never heard anything back from CircleCI, but created a new user locally on my development Mac. This user had no certs or provisioning profiles installed. Then I ran fastlane from the command line using as close to the same setup and commands that circleci uses. I saw the question on the screen, which helped me identify why the question was appearing, and then I was able to fix the problem so the question no longer appeared.

Unfortunately, I don’t remember the specifics of what the actual problem was.

I wish there was a better way to diagnose this type of issue, but none was available at the time.

Good Luck.


#4