HTML Build Artifact showing as text/plain



I’m on CircleCI Enterprise and my html build artifacts are being exported, but when you click on the link, they open as text/plain and don’t render as html


I have the same problem too. Do CircleCI guys work on it?


turns out there is an admin configuration that needs to be enabled. It doesn’t render the html by default to avoid cross site scripting etc


Which configuration option? Where is it? I don’t see it for 1.0 or 2.0 enterprise builds.


The bottom option in the Management Console. Unsafe Content Types

HTML is unsafe due to XSS.