Heroku auto deploy doesn't start

heroku

#1

I have my tests running green, heroku auto deployment set up in the CircleCi settings (confirmed that I have the registered SSH key on my heroku account dashboard).

I have followed the instructions here: https://circleci.com/docs/1.0/continuous-deployment-with-heroku/

Here is my circle.yml file

version: 2
jobs:
  build:
    parallelism: 3
    working_directory: ~/pop-poll
    docker:
      - image: circleci/ruby:2.3-jessie-node-browsers
        environment:
          RAILS_ENV: test
      - image: circleci/postgres:9.4.12-alpine
    steps:
      - checkout

      # Restore bundle cache
      - restore_cache:
          key: rails-demo-{{ checksum "Gemfile.lock" }}

      # Bundle install dependencies
      - run: bundle install --path vendor/bundle

      # Store bundle cache
      - save_cache:
          key: rails-demo-{{ checksum "Gemfile.lock" }}
          paths:
            - vendor/bundle

      # Database setup
      - run: bundle exec rails db:create --trace
      - run: bundle exec rails db:migrate --trace

      # Run rspec in parallel
      - type: shell
        command: |
          bundle exec rspec

      # Save test results for timing analysis
      - store_test_results:
          path: test_results

deployment:
  production:
    branch: master
    heroku:
      appname: pop-poll

The tests run through, all green, and then nothing happens. No reference to heroku or auto deployment at all.

Any thoughts? Thanks in advance for any pointers, it’s driving me nuts.


#2

Hi, an update on this, the links through from project settings land you on the 1.0 docs, but I was using the 2.0 circleci application. I didn’t notice this until I looked at the site on a mobile, where it’s more obvious where you are. My bad.

So, if you’re hitting this problem, make sure you’re looking at the 2.0 docs https://circleci.com/docs/2.0/project-walkthrough/#deploying-to-heroku

Additionally the indentation on the steps outlined in the 2.0 docs didn’t work for me. The documents state:

- add_ssh_keys:
    fingerprints:
      - "48:a0:87:54:ca:75:32:12:c6:9e:a2:77:a4:7:a4"

I found I needed

- add_ssh_keys:
    fingerprints: "6d:55:f3:0c:aa:70:fb:c9:07:f8:db:a8:2c:21"

#3