Gradle 2.10 required, 2.4 is installed



Updated to newest Android Gradle plugin (2.0.0-beta5) which uses the gradle 2.10 distribution. However, circle seems to default to 2.4

Here’s the message I receive:

Gradle version 2.10 is required. Current version is 2.4. If using the gradle wrapper, try editing the distributionUrl in /home/ubuntu/MyProject/gradle/wrapper/ to

But, in my pre, I have the following:

- wget “”; unzip

Anyone have any ideas how to really force the gradle wrapper to use gradle 2.10? Thanks


gradle-2.10 works in my project, you can check it here - (the build fails, but thats espresso tests)

How are you running your build? I’ve got

if [ -e ./gradlew ]; then ./gradlew test assembleDebug connectedAndroidTest -PdisablePreDex;else gradle test assembleDebug connectedAndroidTest -PdisablePreDex;fi

and gradlew is not in the repository