Gradle 2.10 required, 2.4 is installed

android
gradle
circle.yml

#1

Updated to newest Android Gradle plugin (2.0.0-beta5) which uses the gradle 2.10 distribution. However, circle seems to default to 2.4

Here’s the message I receive:

Gradle version 2.10 is required. Current version is 2.4. If using the gradle wrapper, try editing the distributionUrl in /home/ubuntu/MyProject/gradle/wrapper/gradle-wrapper.properties to gradle-2.10-all.zip

But, in my pre, I have the following:

dependencies:
pre:
- wget “https://services.gradle.org/distributions/gradle-2.10-bin.zip”; unzip gradle-2.10-bin.zip

Anyone have any ideas how to really force the gradle wrapper to use gradle 2.10? Thanks


#2

Hi,
gradle-2.10 works in my project, you can check it here - https://github.com/tukak/comicsdbclient/tree/develop (the build fails, but thats espresso tests)

How are you running your build? I’ve got

if [ -e ./gradlew ]; then ./gradlew test assembleDebug connectedAndroidTest -PdisablePreDex;else gradle test assembleDebug connectedAndroidTest -PdisablePreDex;fi

and gradlew is not in the repository


#3