Google Chrome stable is unauthorised package

#1

The following error log I’m getting while installing google chrome stable.
Please suggest me how can I solve that?

OK
Warning: 'apt-key update' is deprecated and should not be used anymore!
Note: In your distribution this command is a no-op and can therefore be removed safely.

Get:1 http://security.debian.org/debian-security stretch/updates InRelease [94.3 kB]

Ign:2 http://deb.debian.org/debian stretch InRelease

Get:3 http://deb.debian.org/debian stretch-updates InRelease [91.0 kB]

Hit:4 http://deb.debian.org/debian stretch Release

Ign:5 http://dl.google.com/linux/chrome/deb stable InRelease

Get:6 http://security.debian.org/debian-security stretch/updates/main amd64 Packages [484 kB]

Get:7 http://dl.google.com/linux/chrome/deb stable Release [943 B]

Get:8 http://dl.google.com/linux/chrome/deb stable Release.gpg [819 B]

Get:9 http://deb.debian.org/debian stretch-updates/main amd64 Packages.diff/Index [8608 B]

Get:10 http://deb.debian.org/debian stretch-updates/main amd64 Packages 2019-03-27-2010.32.pdiff [531 B]

Get:11 http://deb.debian.org/debian stretch-updates/main amd64 Packages 2019-03-30-2008.27.pdiff [1599 B]

Get:11 http://deb.debian.org/debian stretch-updates/main amd64 Packages 2019-03-30-2008.27.pdiff [1599 B]

Ign:8 http://dl.google.com/linux/chrome/deb stable Release.gpg

Get:13 http://dl.google.com/linux/chrome/deb stable/main amd64 Packages [1111 B]

Fetched 683 kB in 0s (2218 kB/s)

Reading package lists... Done

W: GPG error: http://dl.google.com/linux/chrome/deb stable Release: The following signatures were invalid: EXPKEYSIG 1397BC53640DB551 Google Inc. (Linux Packages Signing Authority) <linux-packages-keymaster@google.com>
W: The repository 'http://dl.google.com/linux/chrome/deb stable Release' is not signed.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Reading package lists... Done


Building dependency tree       


Reading state information... Done

The following additional packages will be installed:
  fonts-droid-fallback fonts-noto-mono gsfonts libcupsfilters1 libcupsimage2
  libgs9 libgs9-common libijs-0.35 libjbig2dec0 libpaper-utils libpaper1
  poppler-data
Suggested packages:
  fonts-noto ghostscript-x poppler-utils fonts-japanese-mincho
  | fonts-ipafont-mincho fonts-japanese-gothic | fonts-ipafont-gothic
  fonts-arphic-ukai fonts-arphic-uming fonts-nanum
Recommended packages:
  libu2f-udev
The following NEW packages will be installed:
  fonts-droid-fallback fonts-noto-mono ghostscript gsfonts libcupsfilters1
  libcupsimage2 libgs9 libgs9-common libijs-0.35 libjbig2dec0 libpaper-utils
  libpaper1 poppler-data
The following packages will be upgraded:
  google-chrome-stable
1 upgraded, 13 newly installed, 0 to remove and 10 not upgraded.
Need to get 71.9 MB of archives.
After this operation, 49.7 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  google-chrome-stable
E: There were unauthenticated packages and -y was used without --allow-unauthenticated
Exited with code 100
#2

Hi there, welcome to our community!

Did you run apt-get update before running this step?