Apt-get update fails


#1

My tests need to use apt-get to install a recent version of mongodb.

Starting today when I run apt-get update I get this failure:

W: Failed to fetch http://dl.google.com/linux/chrome/deb/dists/stable/Release  Unable to find expected entry 'main/binary-i386/Packages' in Release file (Wrong sources.list entry or malformed file)

How can I remove dl.google.com from my sources.list?


#2

Hi,

This should only be a temporarily issue on Google’s side however you can remove Google’s repository via a single command in Dependencies.Pre:

dependencies:
  pre:
    - sudo rm /etc/apt/sources.list.d/google*

I hope that helps.


#3

Google has discontinued i386 packages – this might not be coming back.

Also, if you need Chrome for testing via Xvfb or selenium, here’s a better solution – specify the arch needed:

dependences:
    pre:
           - sudo sed -i 's/deb\ http:\/\/dl\.google/deb\ \[arch=amd64\]\ http:\/\/dl\.google/' /etc/apt/sources.list
           - for LIST in $(find /etc/apt/sources.list.d -type f -name *list); do sudo sed -i 's/deb\ http:\/\/dl\.google/deb\ \[arch=amd64\]\ http:\/\/dl\.google/' $LIST; done

#4

https://groups.google.com/a/chromium.org/forum/#!topic/chromium-dev/FoE6sL-p6oU

This is not a temporary issue on Google’s side, the distro for some bizarre reason is trying to find an entry for main/binary-i386/Packages in Google’s Release file, but that has been removed as 32-bit Chrome support was removed this afternoon (see here).

Is 32-bit Chrome installed in the containers for some reason? If so it will need to be changed to the 64-bit version.


#5

Thanks for the info guys. We’ve tracked down the Google change, we’re working on a fix on our end right now.


#6

it’s not. However, the way apt is designed contains multiple arches – it will try to find packages for all support arches.

You need to explain to apt that you’re only looking for amd64 builds on that repo.


#7

My workaround is no longer needed. We have fixed the issue on our end.

Anybody needing to run apt-get update can do so just fine.


#8

@FelicianoTech do you know which version this is updating to? I require greater than 46.0.2490.0 in order to use it in conjunction with chromedriver 2.212.21.371461


#9

Google Chrome v43 is pre-installed. To do a newer version, I would get the .deb. This post has an example: Update Chrome in container image


#10

This is still not working for us. Is this implemented for all CircleCI users?


#11

Sorry, my bad, we were adding the google source from somewhere else


#12