Failed to deploy to platform.sh

#1

I am trying to deploy my app to platform.sh with circleci, by checking out the private github repo and add platformsh remote git and push it?

Here is my config

version: 2
jobs:
  build:
    docker:
      - image: circleci/node:10.15.1
    steps:
      - checkout
      - run:
          name: test
          command: |
            npm i
            npm run build
            npm run pree2e
  deploy:
    docker:
      - image: buildpack-deps:trusty
    steps:
      - add_ssh_keys:
          fingerprints:
            - "b7:35:a6:4e:9b:0d:6d:d4:78:1e:9a:97:2a:66:6b:be"
      - checkout
      - run:
          name: Deploy Master to Platformsh
          command: |
            git config --global user.email "user@example.com"
            git config --global user.name "My Name"
            git clone git@github.com:company/privaterepo.git
            git remote add platform u7p4jj6nzzudw@git.eu-2.platform.sh:u7p4jj6nzzudw.git
            git add ./
            git commit -m "circle ci auto deploy"
            git push platform master

workflows:
  version: 2
  build-deploy:
    jobs:
      - build
      - deploy:
          requires:
            - build
          filters:
            branches:
              only: master

But it was stop on the host verification…

...
[master 0c3a28b] circle ci auto deploy
 1 file changed, 1 insertion(+)
 create mode 160000 platformsh
The authenticity of host 'git.eu-2.platform.sh (34.248.104.12)' can't be established.
RSA key fingerprint is cd:6e:a7:23:c3:eb:b4:d8:9e:59:a8:f4:3d:69:66:5d.
Are you sure you want to continue connecting (yes/no)? Too long with no output (exceeded 10m0s)

is this the correct way to deploy the app to different git repo? Also the RSA fingerprint in the log doesn’t match the ssh private key that I added in the settings. Does anyone know how to fix this?

1 Like
#2

I fixed it by adding

- run:
    name: Add Heroku to known_hosts
    command: ssh-keyscan -H git.eu-2.platform.sh >> ~/.ssh/known_hosts

as per The authenticity of host 'heroku.com (50.19.85.132)' can't be established

2 Likes
closed #3

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.