Failed Build: Exit Code 141

I am using a script that pipes yes to a command. When that command exits, yes is still writing input but the command isn’t listening, so it throws an error (Exit Code 141) despite my command exiting successfully and it all results in CircleCI marking it as a failed build. Is there some way that I can whitelist this exit code without appending || true to my command? Adding this to the end essentially makes it an evergreen test, which is not ideal.

+1 I got the same case than you (to accept licenses from sdkmanager)

Same Issue here.

Anyone with an elegant solution

Nervermind :man_facepalming: I am using gcloud and it has the quiet flag

  gcloud GROUP | COMMAND [--account=ACCOUNT] [--configuration=CONFIGURATION]
        [--flatten=[KEY,...]] [--format=FORMAT] [--help] [--project=PROJECT_ID]
        [--quiet, -q] [--verbosity=VERBOSITY; default="warning"]
        [--version, -v] [-h] [--log-http] [--trace-token=TRACE_TOKEN]
        [--no-user-output-enabled]

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.