Docker & Kubernetes

docker

#1

I would like to have the ability to take my multiple micro-services and run integration tests amongst all of them. We are utilizing kubernetes to orchestrate our containers and we are trying to figure out the best way to get this configuration going in various CI services. Does Circle have the ability to configure multiple microservices together and run integration tests? Thanks!


#2

Or more specifically is there a guide to install Kubernetes on a Circle VM? I am trying to install utilizing the docker based method Kubernetes describes, but I can’t seem to start the kubernetes master. Any help would be great. thanks!


#3

I found https://github.com/circleci/docker-hello-google, perhaps it may help?

It looks like https://circleci.com/gh/circleci/docker-hello-google/32 is a passing build of it.


#4

Yeah I have seen that as well, but that hack/build-go.sh doesn’t work, it freezes in mid-build and it doesn’t install. I have also been looking at the ubuntu standard install and it works for my virtual machine but it doesn’t appear to work on the circle VMs. I am thinking it has something to do with networking or something. It is freezing at this point when I install with ./cluster/kube-up.sh with the ubuntu build.

{“Network”:“172.16.0.0/16”, “Backend”: {“Type”: “vxlan”}}
{“Network”:“172.16.0.0/16”, “Backend”: {“Type”: “vxlan”}}

Also, I was looking at the etcd logs and I see that it is getting a bind address already used which tells me it is a networking issue somewhere.

2015-12-11 16:17:57.752285 I | etcdmain: etcd Version: 2.2.1
2015-12-11 16:17:57.752381 I | etcdmain: Git SHA: 75f8282
2015-12-11 16:17:57.752406 I | etcdmain: Go Version: go1.5.1
2015-12-11 16:17:57.752426 I | etcdmain: Go OS/Arch: linux/amd64
2015-12-11 16:17:57.752450 I | etcdmain: setting maximum number of CPUs to 2, total number of available CPUs is 2
2015-12-11 16:17:57.752479 W | etcdmain: no data-dir provided, using default data-dir ./infra.etcd
2015-12-11 16:17:57.752775 C | etcdmain: listen tcp 127.0.0.1:2380: bind: address already in use


#5

Did you get this working? Or go another direction? I’m facing a similar problem.


#6