Disabling buildkit it remote Docker


I’m trying to run build a Docker image using the remote Docker environment and the docker orb.

When I run the docker build command I get this error:

ERROR: BuildKit is enabled but the buildx component is missing or broken.
       Install the buildx component to build images with BuildKit:

Exited with code exit status 1

I have tried setting DOCKER_BUILDKIT=0 in the job but that makes no difference. How can I disable buildkit?


Can’t seem to edit the post above for some reason, but I wanted to add that I’m using a set of build scripts that call docker directly, so I can’t use the use-build-kit-parameters used by the docker orb.

Without your config.yml it is hard to be certain of what is going wrong, but the first thing that you should check is the docker version being used by the docker orb.

‘docker/publish’ has a parameter ‘remote-docker-version’ that defaults to 17.09.0-ce, which dates back to the end of 2018. So if you are not aware of the parameter things go wrong rather quickly.

DOCKER_BUILDKIT=0 is unlikely to do much until you are deploying docker 23.x.x as before then BuildKit was not the default, but it did not even exist until 18.09