"Could not find did_you_mean-1.3.0 in any of the sources"


I’m not doing anything fancy, just trying to get my build running on circleci.

weirdly there isn’t bundler on the ruby docker images it seems.

and then after running bundle install then doing bundle exec rails db:setup (or really anything like bundle exec rails console etc. (verified with SSH)) I get:

#!/bin/bash -eo pipefail
bundle exec rails db:setup
Could not find did_you_mean-1.3.0 in any of the sources
Run `bundle install` to install missing gems.
Exited with code 7

(even running bundle install on the SSH session (e.g. without the vendored path) doesn’t fix it).

any idea of what I’m doing wrong?

(I also tried to put did_you_mean in other groups in the Gemfile, and doing require: false but didn’t fix it)

full minimal config to reproduce (with gem 'did_you_mean' in Gemfile)

version: 2
    working_directory: ~/app
      - image: circleci/ruby:2.6.3-node-browsers
          PGHOST: localhost
          PGUSER: app
          RAILS_ENV: test

      - image: postgres:9.5
          POSTGRES_USER: app
          POSTGRES_DB: app_test

      - checkout
      - run: gem install bundler
      - run: bundle install --path vendor/bundle
      - run: bundle exec rails db:setup


fixed it with gem install --install-dir vendor/bundle/ruby/2.6.0/ did_you_mean, not sure why it happens on circleci’s docker image but not locally though.

might be important to note this is a “default bundled gem” with ruby (but not loaded with bundler on my rails app by default, thus why it’s in my Gemfile).

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.