Config pack with dynamic configuration not working

Hello!

I’m trying to sue the dynamic configuration to break down the configuration into multiple files.

When I run circleci run config pack locally, it generates the correct file. When I try to insert the command as the script on the continuation config (as shown below),

version: 2.1

# this allows you to use CircleCI's dynamic configuration feature
setup: true

# the continuation orb is required in order to use dynamic configuration
orbs:
  continuation: circleci/continuation@0.1.2

# our defined job, and its steps
jobs:
  setup:
    executor: continuation/default
    resource_class: medium

    working_directory: ~/api
    steps:
      - checkout
      - run:
          name: Generate config
          command: |
             ## HERE ##
             circleci config pack config > generated_config.yml
      - continuation/continue:
          configuration_path: .circleci/generated_config.yml

# our single workflow, that triggers the setup job defined above
workflows:
  setup:
    jobs:
      - setup

It doesn’t work. I tried printing the output of the config pack command and the result was this

I noticed that the circleci CLI version is 1.0.107823-fbe94a30 (but it seems like the latest public version is 0.1.16535+5010eb7).

Am I missing something? Is the config pack command outdated?

Thank you