Cloning a private repo still get and error `Repository not found`

Is there a clear step of what is needed to run this on a private repository?

ERROR: Repository not found.
fatal: Could not read from remote repository

i tried deleting the keys and recreating them
on checkout keys i created a new deploy key and user key but still not working
I also used a machine use but still is not working


In order to add private repos you will need to add your SSH checkout key in your project settings page. We normally only create a key for the project itself that doesn’t have permissions on other private repositories.

Could you please share which steps you were following. Was it out instructions on machine user keys?

Pawan Bahuguna

I am trying to clone a third private repo, only my github user has read access.

I added a user key from ssh keys section on circleci
I confirm circleci key was added to my user
I put that fingerprint on my config.yml ssh keys

When try to clone pipeline give the error:

ERROR: Repository not found.
fatal: Could not read from remote repository.

I rerun build with ssh access.

Try to run clone to private repo and i get the same erro.

I dont know if i am missing something.

Try to use just the user-fingerprint and also if you are having further issue, I would like to know your organization name.Best option is to open support case, so that we can get the details from you.