Circle CI stopped triggering on pushes to github

I’ve read this similar thread here:

but applying the suggestion made no difference. My projects were fine 2 days ago, but now pushes to github don’t trigger circle CI builds anymore on any projects (tested 2), and circle CI doesn’t even reflect the existence of the new commits on the branches. My credits are all fine as well. What should I do to fix this?

1 Like

Can you send a link to your CircleCI pipeline to and I can take a look

Thanks Sebastian, I sent you an email with a link to an older pipeline that hasn’t triggered since.

Hey @sebastian-lerner, I am having a similar issue with our CircleCI pipelines. Everything seemed to be running fine untila bout 5 days ago and since then any pushers to PRs or even merges into main are not triggering any workflows to start. Nothing has changed in our circleci config file and I am struggling to find the issue.

When attempting to set up a new trigger in circleci via Github it says “No configuration to run available” so I wonder is it not seeing the config file and why this could be occuring?


Im having the same issue. It worked fine 2 days ago. I have been using it for the last 2 months and didnt make any configuration change neither on CircleCi, Github, ssh keys or the circleci/config.yml file. Please check the issue.

1 Like

I tried again today (15 hrs later from my last try) and it worked right.

@ignacioplanella and @sean-hickey-wf , would you mind confirming that the issue is resolved for you too?
And could you also share your projectID with me - either by DM on here or by email to We want to make sure we understand what happened.

Hey Benny,

I was able to fix the problem by:

  1. Unfollowing the project
  2. deleting the trigger
  3. following the project again and creating a new trigger with a new ssh key

I don’t know why this was required but by doing all of this we have our ci/cd pipelines working again

1 Like