CI not triggered after commit or submitting a PR


#1

We have Circle CI set up on our open source project docsocsf/mad which is on GitHub and on my fork martinzlocha/mad but commits I made today are not being built automatically (everything worked fine a few days ago). My other repositories are building fine.

Circle CI is in the webhooks sections for both of these repositories and the hooks are being sent correctly. We also have “Build forked pull requests” enabled so that shouldn’t be an issue.

We have recently added a Slack integration to docsocsf/mad but not to my forked repo. (Doubt this has any impact given that I have Circle CI and Slack set up on other repositories but thought it might be worth mentioning)

Not sure what else could be the issue.

Edit: I tried removing and adding the repository to circle ci. It build the “latest” commit (it is on master) but its not actually the latest commit - the latest one is on a branch. Not sure why its not registering changes made on branches. I have not specified in circle.yml that it should only build master and before it built other branches correctly as well.

Edit 2: Fixed by completely removing the repository from Circle CI and then adding it again.


#2