Checkout Key not working on local build

circle.yml

#1

Hi,

I tried to build locally but the checkout-key isn’t working when I tried to check if it can authenticate Github. Below is the command:
circleci build --checkout-key ~/.ssh/XXXXX -c .circleci/config.yml --job XXXX

But it outputs the following:
====>> Spin up Environment
Build-agent version 0.0.5895-01cdb92 (2018-05-29T20:07:10+0000)
Starting container circleci/ruby:2.5-stretch
using image circleci/ruby@sha256:16a86eeecc753d0acb2334dad41580c4c2fd5321596e9d7e8cdd28be12f9f60c

Using build environment variables:
  BASH_ENV=/tmp/.bash_env-localbuild-1533092935
  CI=true
  CIRCLECI=true
  CIRCLE_BRANCH=4-1-stable
  CIRCLE_BUILD_NUM=
  CIRCLE_JOB=XXXX
  CIRCLE_NODE_INDEX=0
  CIRCLE_NODE_TOTAL=1
  CIRCLE_REPOSITORY_URL=git@github.com:itsmechlark/XXXXX.git
  CIRCLE_SHA1=8b5205fd12c12a61520448371ade1226XXXXXX
  CIRCLE_SHELL_ENV=/tmp/.bash_env-localbuild-1533092935
  CIRCLE_WORKING_DIRECTORY=~/repo

====>> Checkout code
  #!/bin/sh
mkdir -p /home/circleci/repo && cp -r /tmp/_circleci_local_build_repo/. /home/circleci/repo
====>> Clone repo
  #!/bin/bash -eo pipefail
ssh -Tv git@github.com

OpenSSH_7.4p1 Debian-10+deb9u3, OpenSSL 1.0.2l  25 May 2017
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to github.com [192.30.253.113] port 22.
debug1: Connection established.
debug1: SELinux support disabled
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_rsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_dsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/circleci/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_7.4p1 Debian-10+deb9u3
debug1: Remote protocol version 2.0, remote software version libssh_0.7.0
debug1: no match: libssh_0.7.0
debug1: Authenticating to github.com:22 as 'git'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: curve25519-sha256@libssh.org
debug1: kex: host key algorithm: ssh-rsa
debug1: kex: server->client cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: kex: client->server cipher: chacha20-poly1305@openssh.com MAC: <implicit> compression: none
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: ssh-rsa SHA256:nThbg6kXUpJWGl7E1IGOCspRomTxdCARLviKw6E5SY8
The authenticity of host 'github.com (192.30.253.113)' can't be established.
RSA key fingerprint is SHA256:nThbg6kXUpJWGl7E1IGOCspRomTxdCARLviKw6E5SY8.
Are you sure you want to continue connecting (yes/no)? yes
Error: Too long with no output (exceeded 10m0s)
Step timedout
Task failed

I don’t know if I configure it correctly.