Can't access private repositories of organization

ios
fastlane

#1

I belong to an organization in Github.

The organization has some private repositories that need to be accessed during the build.

One is a repository containing the certificates/provisioning profiles. I’m using fastlane match, which uses this repository to do the build. The other is not really important and can be made public if necessary.

fastlane match isn’t working, apparently because it can’t access the private repository. I tried out ssh access. I first unlocked the keychain:

security unlock-keychain -p circle ${HOME}/Library/Keychains/circle.keychain

Then tried to clone the repository:

git clone ‘https://github.com/xxxx/certs’ '/var/folders/jm/fw86rxds0xn69sk40d18y69m0000gp/T/
I get this:

ERROR: Repository not found.
fatal: Could not read from remote repository.

Please make sure you have the correct access rights

(The repository definitely exists)

Edit: I learned that it’s necessary that the owner of the repo (in this case of the organization, which I assume is the same) adds his user key. He did but it had no effect.

What can be causing this?

Edit 2: I assume that I don’t have to add any certificates to Circle since this is all done by fastlane match. This also doesn’t seem related with the problem of not being able to access the private repositories.

This is my circle.yml

machine:
  xcode:
    version: 8.0

dependencies:
  pre:
    - security unlock-keychain -p circle ${HOME}/Library/Keychains/circle.keychain

  override:
    - bundle install:
        timeout: 240

deployment:
  mybeta:
    branch: [circletest]
    commands:
      - bundle exec fastlane beta

test:
  override:
    - echo ""

Thanks!


#2

Ok, I forked the organization repos to my own repo, linked to the fork, re-added my user key and it’s working. Will test in the future again with the org repo.


#3

I have some problem with this.
Have you figured this out?
Please let me know how to do it if you figured this out.


#4